IPB

>

Debian

 
 ДмитрийТ
сообщение 09.05.2013, 01:03
Сообщение #1


СССР
********************

Группа: Участник
Сообщений: 4363
Регистрация: 28.12.2008
Из: РСФСР
Пользователь №: 9611




Разработчик – сообщество http://www.debian.org/devel/people
Актуальная версия – Debian 7.3 Wheezy Ядро Linux версии 3.2
Основные изменения
- Поддержка новых архитектур: s390x и armhf
- Официальная поддержка Debian GNU/kfreebsd (в Debian 6.0 сборка с ядром BSD имела статус технологического превью)
- Новое ядро Linux версии 3.2 (с огромным количеством изменений по сравнению с той же версией ядра из mainline — подробности)
- Полная поддержка multiarch
- По умолчанию используется файловая система ext4
- Новый Debian-installer с возможностью установки на системы с uefi (secure-boot не поддерживается), полной поддержкой IPv6, поддержкой установки через wi-fi с wpa шифрованием и наличием голосовой озвучки установки для слабовидящих людей.
- В репозитории теперь имеются сборки ядра Linux с патчами для работы в реальном времени
- OpenOffice.org заменен на Libreoffice версии 3.5
- Koffice заменен на его продолжение — Calligra suite версии 2.4
- Новые версии программ: Gnome 3.4, KDE 4.8, Xfce 4.8, eglibc 2.13, xserver-xorg 1.12, GIMP 2.8, MySQL 5.5, Apache 2.2.22, GCC 4.7, PHP 5.4, Perl 5.14, Python 2.7, Python3 3.2, Samba 3.6, Iceweasel 10 ESR, Chromium-browser 26
- Ffmpeg заменен на его форк libav
- Опциональная поддержка systemd. В качестве основной системы инициализации по-прежнему используется sysvinit с распараллеливанием загрузки с помощью insserv.
- Поддержка файловой системы exFAT
- Новый каталог /run, куда перенесено содержимое /var/run
- Поддержка apparmor
- В Gnome в качестве основного графического менеджера пакетов вместо Software-center используется PackageKit
- Поддержка облачных платформ Xen Cloud Platform, Openstack, Amazon EC2, Windows Azure, Google Computer Engine
- Теперь Debian соответствует стандарту LSB 4.1 за исключением отсутствия поддержки Qt3

Следующая версия - Debian 8.0 Jessie 
Oldstable версия - Debian 6.0 Squeeze, окончание поддержки 04.05.2014г
Официальный сайтhttp://www.debian.org
Форум на русском языкеhttp://debianforum.ru
Документация на русском языке <a href="http://www.debian.org/doc/" target="_blank" rel="nofollow">http://www.debian.org/doc/</a>

Проект Debian — это ассоциация людей, общим делом которых является создание свободной операционной системы. Создатель и вдохновитель проекта Иэн Мэрдок (Ian Murdock)
Системы Debian сейчас используют ядро Linux или FreeBSD. Linux начал разрабатывать Линус Торвальдс (Linus Torvalds), и которое поддерживают тысячи программистов по всему миру. FreeBSD — это операционная система, включающая ядро и другое ПО.
Тем не менее, ведётся работа по созданию систем Debian на других ядрах, в первую очередь, на the Hurd. Hurd - это набор серверов, которые запускаются поверх микроядра (например, такого как Mach) и реализуют разные возможности. Hurd - это свободное программное обеспечение, разрабатываемое в рамках Проекта GNU (GNU Project).


Установочные образы:

- amd64
- i386

Инструкция по установке:
- установка на 64-битный ПК (amd64)
- установка на 32-битный ПК (i386)
- для установки по сети

обложки для дисков можно взять тут: <a href="http://www.debian.org/CD/artwork/" target="_blank" rel="nofollow">http://www.debian.org/CD/artwork/</a>

Сообщение отредактировал ДмитрийТ - 11.01.2014, 20:58
Перейти в начало страницы
 
 
 
 
Ответов
 ДмитрийТ
сообщение 13.05.2013, 02:54
Сообщение #2


СССР
********************

Группа: Участник
Сообщений: 4363
Регистрация: 28.12.2008
Из: РСФСР
Пользователь №: 9611



Начата разработка Debian 8.0 – Jessie (продолжает традицию присвоения имён из мультфильма «История игрушек» (Toy Story)).

Матиас Клозе [Matthias Klose] сообщает о выполненных изменениях в toolchain: ведётся работа по переходу на glibc 2.17, binutils 2.23.2 и GCC 4.8, пакет linux-libc-dev обновлён до версии 3.8.11.
Перейти в начало страницы
 
 
 cjayho
сообщение 13.05.2013, 19:22
Сообщение #3


Игроман
**********

Группа: Участник
Сообщений: 892
Регистрация: 08.03.2010
Пользователь №: 13783



Юзаю визи амд64, собираюсь все серваки тоже на нее переводить. Из заметных багов было разве что замечено, что тотем в гноме3 через раз начинает играть мп3, я отсылал багрепорт но почему-то глухо. Самому коды покопать что ли...
И кстати единственный дистр на котором с моим радеоном 4650 завелось 3д на опенсорсных дровах (надо всего лишь поставить пакет firmware-linux).
Перейти в начало страницы
 
 
 NotecX
сообщение 13.05.2013, 22:32
Сообщение #4


Почти Мастер
***********

Группа: Участник
Сообщений: 1227
Регистрация: 26.12.2008
Пользователь №: 9605



Цитата(cjayho @ 13.05.2013, 20:18) *
единственный дистр на котором с моим радеоном 4650 завелось 3д на опенсорсных дровах

Оно у меня на убунтах работало с этой картой, пожалуй, с релиза 11.10.
Дебиан клевая штука, хотя со спецификой.
Перейти в начало страницы
 
 
 ДмитрийТ
сообщение 14.05.2013, 09:09
Сообщение #5


СССР
********************

Группа: Участник
Сообщений: 4363
Регистрация: 28.12.2008
Из: РСФСР
Пользователь №: 9611



Цитата(NotecX @ 13.05.2013, 23:29) *
Дебиан клевая штука, хотя со спецификой.

согласен, во первых ку да как стабильнее той же ubuntu, хотя есть и минус по 7 еще не знаю, но шестерка на мою рабочую материнку так и не встала, зациклилась на монтировании привода и пипец не в какую, пришлось 13.04 ставить, что то же неплохо для работы.
Перейти в начало страницы
 
 
 ДмитрийТ
сообщение 04.06.2013, 14:22
Сообщение #6


СССР
********************

Группа: Участник
Сообщений: 4363
Регистрация: 28.12.2008
Из: РСФСР
Пользователь №: 9611



Debian меняет политику поддержки продуктов Mozilla
Группа Debian

Вплоть до настоящего времени такие продукты Mozilla как Firefox, Thunderbird и Seamonkey (в виде, соответственно, Iceweasel, Icedove и Iceape - версий без собственнических торговой марки и логотипов) поддерживались в стабильном выпуске Debian путём переноса исправлений ошибок из новых версий в текущую. Однако, такой подход требовал слишком больших человеческих и временных ресурсов, поэтому было решено от него отказаться.

Отныне в стабильном выпуске Debian, начиная уже с текущего (7.0 wheezy), будут содержаться актуальные версии с расширеннной поддержкой (ESR - Extended Support Release) данных программ.

Таким образом, Iceweasel версии 10 ESR, поддержка которой заканчивается, будет обновлён до актуальной версии 17 ESR, а затем - до следующей ESR-версии, когда закончится поддержка последней.

Некоторые расширения xul-*, содержащиеся в репозитории Debian, не совместимы с новой версией Iceweasel. В качестве временного решения предлагается их установка с http://addons.mozilla.org/. В настоящее время обсуждаются возможные решения данной проблемы.

Поддержка Iceweasel, Icedove и Iceape в старом стабильном выпуске (6.0 squeeze) ввиду недостатка человеческих ресурсов прекращена. Если у вас есть возможность и желание заняться их поддержкой, пишите на [email protected]

Подробности тут: http://www.debian.org/security/2013/dsa-2699
Источник:
lunix.org.ru

Сообщение отредактировал ДмитрийТ - 04.06.2013, 14:23
Перейти в начало страницы
 
 
 Свидомит
сообщение 27.02.2014, 22:10
Сообщение #7


RMS
**********************

Группа: Забанен
Сообщений: 6908
Регистрация: 08.01.2010
Из: Украина, Луганск
Пользователь №: 13451



Поставил себе Дебиан. Опять. Подскажите, на какой репозиторий лучше всего настроить синаптик?
Перейти в начало страницы
 
 
 jamakasi
сообщение 27.02.2014, 22:26
Сообщение #8


Кандидат Игровых Наук
******************

Группа: Участник
Сообщений: 3099
Регистрация: 12.07.2007
Из: Энгельс
Пользователь №: 6560



Что то дебиан для десктопа расстраивает в последнее время, я понимаю что стабильность превыше всего но "кастрировать" отдельные и довольно важные части это уже слишком. Давеча столкнулся с просто мировой проблемой, принтер кенон и вафля в ноуте, убил пол дня на гугление и подцепление проприетарных прошивок к этим девайсам (IMG:style_emoticons/default/mad.gif) . Для серверов бесспорно бедка лучше чем бубунта.
Перейти в начало страницы
 
 
 Свидомит
сообщение 02.03.2014, 21:20
Сообщение #9


RMS
**********************

Группа: Забанен
Сообщений: 6908
Регистрация: 08.01.2010
Из: Украина, Луганск
Пользователь №: 13451



Пытаюсь поставить проприетарный драйвер ati legacy 13.1 Дистрибутив - Debian 7.04 amd64
videocard - hd 4350
https://wiki.debian.org/ATIProprietary
При aptitude -r -t wheezy-backports install fglrx-legacy-driver
Цитата
E: Значение «wheezy-backports» недопустимо для APT::Default-Release, так как выпуск недоступен в источниках
E: Значение «wheezy-backports» недопустимо для APT::Default-Release, так как выпуск недоступен в источниках

В синаптике же ругается на сломаные пакеты. При попытке выбрать в синаптике пункт "исправить пакеты" ругается вот так:
Цитата
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.
E: Невозможно исправить зависимости
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.
E: Невозможно исправить зависимости


ЧЯДНТ?

Сообщение отредактировал Митрополит Флуда Camblu - 02.03.2014, 21:23
Перейти в начало страницы
 
 
 ДмитрийТ
сообщение 02.03.2014, 21:33
Сообщение #10


СССР
********************

Группа: Участник
Сообщений: 4363
Регистрация: 28.12.2008
Из: РСФСР
Пользователь №: 9611



Митрополит Флуда Camblu,
Цитата
sudo apt-get install -f
sudo dpkg --configure -a

Пробовал?


а вообще лучше сделать так

aptitude search drbd

и посмотреть какие пакеты битые

Сообщение отредактировал ДмитрийТ - 02.03.2014, 21:37
Перейти в начало страницы
 
 
 Свидомит
сообщение 02.03.2014, 21:38
Сообщение #11


RMS
**********************

Группа: Забанен
Сообщений: 6908
Регистрация: 08.01.2010
Из: Украина, Луганск
Пользователь №: 13451



ДмитрийТ, Вроде поставилось. А дальше - по инструкции?
Перейти в начало страницы
 
 
 ДмитрийТ
сообщение 02.03.2014, 21:43
Сообщение #12


СССР
********************

Группа: Участник
Сообщений: 4363
Регистрация: 28.12.2008
Из: РСФСР
Пользователь №: 9611



Цитата(Митрополит Флуда Camblu @ 02.03.2014, 22:35) *
ДмитрийТ, Вроде поставилось. А дальше - по инструкции?

Да только проверь наличие пакетов для дров Ati:https://wiki.debian.org/ru/ATIProprietary
Перейти в начало страницы
 
 
 ДмитрийТ
сообщение 19.03.2014, 23:41
Сообщение #13


СССР
********************

Группа: Участник
Сообщений: 4363
Регистрация: 28.12.2008
Из: РСФСР
Пользователь №: 9611



Первый альфа-выпуск инсталлятора Debian 8 "Jessie"
Началось тестирование первой альфа-версии инсталлятора следующего значительного релиза Debian - "Jessie". Перевод пакетной базы Debian 8 на стадию заморозки, при которой процесс переноса пакетов из unstable в testing будет остановлен и начнётся этап интенсивного тестирования и исправления блокирующих релиз проблем, ожидается 5 ноября 2014 года. Наиболее вероятно, что релиз будет выпущен в начале весны следующего года.

Ключевые изменения в инсталляторе:

  • В качестве десктоп-окружения по умолчанию вместо GNOME теперь предлагается Xfce. Указанное изменение является оценочным, решение о возврате к GNOME или продолжении использования Xfce будет принято в августе на основании отзывов пользователей и анализа частоты выбора GNOME, несмотря на изменение предложения по умолчанию;
  • Возможность выбора альтернативного рабочего стола для установки на стадии приглашения загрузчика. Установочные образы подготовлены для всех популярных десктоп-окружений;
  • Прекращена поддержка архитектуры ia64;
  • Архитектура s390 заменена на s390x;
  • Прекращена поддержка формирования установочных образов для архитектуры SPARC. Решение о будущем поддержки архитектуры SPARC ещё не принято;
  • Ядро Linux обновлено до версии 3.13 (в Debian 7 используется 3.2), ядро FreeBSD обновлено до версии 9.2 (в Debian 7 используется 9.0);
  • В grub-installer добавлено отображение меню на загрузочном диске с GRUB;
  • Обновлены многие компоненты дистрибутива и версии программ.


Основные цели, намеченные для реализации в Debian 8.0:

  • Использование по умолчанию системного менеджера systemd;
  • Поддержка Clang в качестве вторичного компилятора;
  • Обеспечение возможности использования системы принудительного контроля доступа SELinux (в режиме enforcing);
  • Задействование дополнительных механизмов обеспечения безопасности, интегрируемых в исполняемые файлы ELF (Position Independent Executable, защита стека, Fortify Source, Read-only relocations, Immediate binding). Активация флагов сборки с использованием дополнительных механизмов безопасности для как можно большего числа пакетов, которые работают с внешними данными (сетевые серверы, браузеры, просмотрщики контента и т.п.);
  • Включение инструментов кросс-компиляции в архив и обеспечение из коробки средств для кросс-сборки базовой системы (можно будет разом и без установки внешних инструментов кросс-скомпилировать 140 пакетов, составляющих минимальную базовую систему);
  • Упорядочивание использования сборочных флагов CC/CXX;
  • Проведение чистки архива пакетов для прохождения пакетами тестов piuparts;
  • Полная поддержка UTF-8 во всех пакетах (поддержка ввода и отображения в UTF-8 по умолчанию, поставка всех текстовых файлов в UTF-8, поставка в пакетах файлов только с именами в кодировке UTF-8).

Источник opennet.ru
Перейти в начало страницы
 
 
 jamakasi
сообщение 16.04.2014, 20:28
Сообщение #14


Кандидат Игровых Наук
******************

Группа: Участник
Сообщений: 3099
Регистрация: 12.07.2007
Из: Энгельс
Пользователь №: 6560



Не мог не поделиться счастьем приобретения чуда (IMG:style_emoticons/default/rolleyes.gif)
(IMG:http://images.gameru.net/thumb/9b9651011a.jpg)
Перейти в начало страницы
 
 
 Son1c
сообщение 18.07.2014, 22:41
Сообщение #15


Продвинутый геймер
********

Группа: Забанен
Сообщений: 382
Регистрация: 24.08.2007
Пользователь №: 6718



Цитата(jamakasi @ 16.04.2014, 20:24) *
Не мог не поделиться счастьем приобретения чуда rolleyes.gif

(IMG:style_emoticons/default/rolleyes.gif)
(IMG:http://images.gameru.net/thumb/b25a5a86d8.png)
Перейти в начало страницы
 
 
 ДмитрийТ
сообщение 17.10.2014, 13:41
Сообщение #16


СССР
********************

Группа: Участник
Сообщений: 4363
Регистрация: 28.12.2008
Из: РСФСР
Пользователь №: 9611



В Debian 8 «Jessie» будет оставлена возможность использования других систем инициализации вместо Systemd

В интервью проекту ITWire Лукас Нуссбаум (Lucas Nussbaum) подтвердил, что пользователи смогут продолжить использовать операционные системы Debian GNU/Linux с системой инициализации Sysvinit.

Несмотря на принятое в феврале этого года решение о переходе на Systemd в качестве систему инициализации по умолчанию для релиза Debian Jessie, в ветке Testing в настоящее время доступен пакет systemd-shim, который позволяет использовать функционал Systemd без использования самого Systemd в качестве системы инициализации, таким образом по-прежнему используя SysVInit или, например, Upstart для управления загрузкой.

Пакет systemd-shim будет доступен далее и будет поддерживаться в Debian Jessie. По умолчанию же по-прежнему будет устанавливаться Systemd.

systemd-shim - «заглушка», предоставляющая dbus-интерфейс Systemd для служб, нуждающихся в нем (таких, как logind, timedated и др.), без необходимости запуска Systemd в качестве системы инициализации (т.е. как init можно по-прежнему использовать sysvinit или любую другую систему). однако, этот пакет предоставляет только dbus-интерфейс org.freedesktop.systemd1.service, для остальных (org.freedesktop.hostname1.service, org.freedesktop.locale1.service, eorg.freedesktop.login1.service и других) все же потребуется установка пакета systemd и использование соответствующих утилит (например, новые версии LightDM не работают без logind, GNOME требует наличия многих служб Systemd).

Подробнее о systemd-shim можно узнать из этого письма сопровождающего данного пакета и дальнейшего обсуждения >>>>

Источник https://www.linux.org.ru
Перейти в начало страницы
 
 
 
 

 
2 чел. читают эту тему (гостей: 2, скрытых пользователей: 0)
Пользователей: 0

 

Текстовая версия Сейчас: 29.05.2017, 03:08