IPB

 
>

LevelEditor 1935, а на самом деле он 'xrCore' build 1928, Oct

, Получилось запустить.

 
 ed_dream
сообщение 28.02.2009, 00:41
Сообщение #1


Игроман
**********

Группа: Участник
Сообщений: 823
Регистрация: 14.01.2006
Пользователь №: 2804



Удалось запустить LevelEditor от 1935 - 'xrCore' build 1928, Oct 11 2004 .
Использовал распакованный стандартный билд, без всего - модов пачй и тд.
Создал дополнительно fs.ltx изменял fsgame.ltx
(IMG:http://img15.imageshack.us/img15/5861/leveled.jpg)
By ed_dream
http://www.sendspace.com/file/cd83sy
Я спать дальше копайте сами, возможно еще допилить надо будет.
Прямые пути поменяйте на свои есно.
Перейти в начало страницы
 
 
 RAIMAN
сообщение 28.02.2009, 00:48
Сообщение #2


Опытный Игрок
****

Группа: Участник
Сообщений: 70
Регистрация: 28.03.2007
Пользователь №: 5719



Теперь можно делать с локациями всё что угодно? Мапперы - отодвиньте, пожалуйста, заборы как можно дальше!
Перейти в начало страницы
 
 
 BAC9-FLCL
сообщение 28.02.2009, 01:01
Сообщение #3


Lo Res Chairman
**************

Группа: Участник
Сообщений: 1796
Регистрация: 09.09.2007
Пользователь №: 6792



Уровни и объекты можно открыть и в SDK от ТЧ. UI здесь тот же, функционал хуже, стабильность ниже.
Компиляторы (кроме xrAI) к этому LE не приложены, так что практического смысла в нем вообще никакого.

P.S.: Помнится, кто-то говорил, что мол, разработчики пользовались другим SDK с куда более крутым UI и функционалом. Смотрим скрин и обламываемся (IMG:http://www.gameru.net/forum/style_emoticons/default/smile.gif)

Сообщение отредактировал BAC9-FLCL - 28.02.2009, 01:11
Перейти в начало страницы
 
 
 Jesh
сообщение 28.02.2009, 01:08
Сообщение #4


Грандмастер
**************

Группа: Участник
Сообщений: 1951
Регистрация: 22.07.2008
Из: Укропленд
Пользователь №: 8477



также для полноценной работы Level Editor потребуется распаковать gamedata и скопировать в образовавшуюся в корне с билдом(если несделать этого, то начнёт выкидать ошибку вроде: нехватает файла shaders_xrlc.xr и других)
Перейти в начало страницы
 
 
 macron
сообщение 28.02.2009, 01:12
Сообщение #5


Игровой Бог
**********************

Группа: Участник
Сообщений: 6163
Регистрация: 22.02.2006
Из: Париж
Пользователь №: 3089



Цитата(BAC9-FLCL @ 28.02.2009, 01:01) *
Уровни и объекты можно открыть и в SDK от ТЧ. UI тот же, функционал хуже, стабильность ниже.
Компиляторы (кроме xrAI) к этому LE не приложены, так что практического смысла в нем вообще никакого.

Поживем-увидим. Может, с этим SDK можно будет создавать совместимые с 1935 спавны для mp или даже кооператива (в теории). Хотя, в принципе для mp подходят и level.game, созданные в ТЧ-SDK.

Цитата
P.S.: Помнится, кто-то говорил, что мол, разработчики пользовались другим SDK с куда более крутым UI и функционалом. Смотрим скрин и обламываемся

А разве сами разрабы не твердили, что у них есть mp-sdk и сингл-sdk, который никому не дадут?
Перейти в начало страницы
 
 
 plusquam
сообщение 28.02.2009, 01:12
Сообщение #6


Игрок
***

Группа: Только зарегистрировался
Сообщений: 32
Регистрация: 26.02.2009
Пользователь №: 10015



не хочет карты открывать. база распакованная.

апд

подправил $maps$ на =true, true, теперь ругается на $objects$

апд2

объекты редактор видит, теперь проблемы с $textures$ - вылетает с руганью

да, и в логах матюки на объекты different version или что-то типа

Сообщение отредактировал plusquam - 28.02.2009, 01:32
Перейти в начало страницы
 
 
 BAC9-FLCL
сообщение 28.02.2009, 01:28
Сообщение #7


Lo Res Chairman
**************

Группа: Участник
Сообщений: 1796
Регистрация: 09.09.2007
Пользователь №: 6792



Цитата(macron @ 28.02.2009, 01:12) *
А разве сами разрабы не твердили, что у них есть mp-sdk и сингл-sdk, который никому не дадут?

=)

Собственно, не дали только xrAI, а в целом 0.4 - это полноценный SDK. Кто-нибудь из PR-отдела, конечно, мог быть уверен в том, что 0.4 - это совершенно другая версия, подходящая только для MP, "а полную SP-версию мы вам не дадим", но технически же это не так. Разделение на SP/MP, в общем, только в головах у непричастных к SDK товарищей (IMG:http://www.gameru.net/forum/style_emoticons/default/smile.gif)

Цитата(plusquam @ 28.02.2009, 01:12) *
да, и в логах матюки на объекты different version или что-то типа

Это традиционная ругань, не обращай внимания )) Похоже, SDK даже из-за изменившихся дат в файле уже считает его другой версией.

P.S.: В любом случае автору плюс за то, что нашел время поработать и запустить (IMG:http://www.gameru.net/forum/style_emoticons/default/smile.gif)

Сообщение отредактировал BAC9-FLCL - 28.02.2009, 01:57
Перейти в начало страницы
 
 
 Лохотрон
сообщение 28.02.2009, 02:08
Сообщение #8


разраб одиночка
******************

Группа: Модератор
Сообщений: 3322
Регистрация: 06.05.2004
Из: коморка
Пользователь №: 697



открыл в этом le эскейп, там исхи всего включая все спавны и даже травы, там где она есть...
вообщем это мододелам полноценная замена acdc для этого билда, компилятор аи имеется так что, руки в ноги и вперед

Сообщение отредактировал Loxotron - 28.02.2009, 02:09
Перейти в начало страницы
 
 
 Cigarette Smokin...
сообщение 28.02.2009, 02:10
Сообщение #9


THE TRUTH IS OUT THERE
****************

Группа: Забанен
Сообщений: 2516
Регистрация: 17.08.2008
Из: иев
Пользователь №: 8662



Цитата
открыл в этом le эскейп, там исхи всего включая все спавны и даже травы, там где она есть...
вообщем это мододелам полноценная замена acdc для этого билда, компилятор аи имеется так что, руки в ноги и вперед


У меня и в LE для ТЧ нормально открыватся. (IMG:http://www.gameru.net/forum/style_emoticons/default/wink.gif)
Перейти в начало страницы
 
 
 Fixer
сообщение 28.02.2009, 02:11
Сообщение #10


Опытный Игрок
****

Группа: Участник
Сообщений: 70
Регистрация: 25.02.2009
Пользователь №: 10008



2 BAC9-FLCL

Народ что-то не может перенести локации с 1935 на 2215, ругается на:

exp​ression: XRCL_PRODUCTION_VERSION==H.XRLC_version
Incompatible level version.

Может знаеш что-то?
Перейти в начало страницы
 
 
 Лохотрон
сообщение 28.02.2009, 02:12
Сообщение #11


разраб одиночка
******************

Группа: Модератор
Сообщений: 3322
Регистрация: 06.05.2004
Из: коморка
Пользователь №: 697



Цитата
У меня и в LE для ТЧ нормально открыватся.

у меня без спавнов фактически там

Сообщение отредактировал Loxotron - 28.02.2009, 02:12
Перейти в начало страницы
 
 
 s\R
сообщение 28.02.2009, 08:01
Сообщение #12


Геймер
******

Группа: Участник
Сообщений: 140
Регистрация: 22.10.2008
Пользователь №: 9336



Я что то не пойму, карты новые никто не компилит просто потому что времени сутки займет?!



Мортарион, Loxotron, plusquam, ed_dream, ну Шта!? нужны скетчи на новые просторы?
Перейти в начало страницы
 
 
 DANGER
сообщение 28.02.2009, 08:38
Сообщение #13


Продвинутый геймер
********

Группа: Участник
Сообщений: 343
Регистрация: 03.11.2008
Пользователь №: 9394



во как раз надо щас спавн поправить раз запустили спасибо вам давно хотел собрать спавн для 1935 терь смогу на родном ле!!!
Перейти в начало страницы
 
 
 Pxan
сообщение 28.02.2009, 08:52
Сообщение #14


Игроман
**********

Группа: Участник
Сообщений: 823
Регистрация: 17.08.2008
Пользователь №: 8665



Во!, спавн надо поправить, я конечно понимаю, что плохо когда пустые локи, но 20 кровососов против 30 зомбарей, эт слишком (IMG:http://www.gameru.net/forum/style_emoticons/default/z_crazy.gif)
Перейти в начало страницы
 
 
 =Diablo=
сообщение 28.02.2009, 11:03
Сообщение #15


Игроман
**********

Группа: Участник
Сообщений: 884
Регистрация: 14.08.2008
Пользователь №: 8611



Народ, а попробуйте скомпилировать левел с помощью xrLC.exe от 2215 билда, должно работать...
Перейти в начало страницы
 
 
 ed_dream
сообщение 28.02.2009, 11:16
Сообщение #16


Игроман
**********

Группа: Участник
Сообщений: 823
Регистрация: 14.01.2006
Пользователь №: 2804



Плочти последние fs.ltx и fsgame.ltx
У меня они одиаковые.
Можно конечно на относительные пусти все переиграть и это наверное важно для компиляции, но пока я абсолютными балуюсь.

CODE

$local_root$ =false, false, D:\Download\Games\stalker\ST\1935\build\
$server_root$ =false, false, D:\Download\Games\stalker\ST\1935\build\
$server_data_root$ =false, false, D:\Download\Games\stalker\ST\1935\build\
$maps$ =true, true, D:\Download\Games\stalker\ST\1935\build\maps\
$temp$ =false, false, D:\Download\Games\stalker\ST\1935\build\temp\
$app_root$ =false, false, D:\Download\Games\stalker\ST\1935\build\
$objects$ =true,true, D:\Download\Games\stalker\ST\1935\build\objects\
$import$ =true, true, D:\Download\Games\stalker\ST\1935\build\objects\
$textures$ =false, false, D:\Download\Games\stalker\ST\1935\build\gamedata\textures\
;abbreviation = recurs,notif, root, add, ext, description
$game_data$ = false, true, gamedata\
$game_ai$ = true, false, $game_data$, ai\
$game_spawn$ = true, false, $game_data$, spawns\
$game_anims$ = true, true, $game_data$, anims\
$game_levels$ = true, false, $game_data$, levels\
$game_meshes$ = true, true, $game_data$, meshes\
$game_dm$ = true, true, $game_data$, meshes\
$game_shaders$ = true, true, $game_data$, shaders\
$game_sounds$ = true, true, $game_data$, sounds\
$game_textures$ = true, true, $game_data$, textures\
$game_scripts$ = true, false, $game_data$, scripts\
$level$ = false, false, $game_levels$
$game_saves$ = true, false, savedgames\
$logs$ = true, false, logs\
$screenshots$ = true, false, screenshots\
$cache$ = true, false, xr_cache\


Сообщение отредактировал ed_dream - 28.02.2009, 11:25
Перейти в начало страницы
 
 
 =Diablo=
сообщение 28.02.2009, 11:19
Сообщение #17


Игроман
**********

Группа: Участник
Сообщений: 884
Регистрация: 14.08.2008
Пользователь №: 8611



А вот мой практически финальный вид fs.ltx
CODE
$sdk_root$ = false, false, E:\Stk1935\sdk1935_beta
$local_root$ = false, false, $sdk_root$
$sdk_root_raw$ = false, false, $sdk_root$, rawdata\
$app_root$ = false, false, $sdk_root$
$server_root$ = false, false, $sdk_root$
$server_data_root$ = false, false, $sdk_root$
$server_backup$ = true, false, $sdk_root$, backup\
;
$game_data$ = false, true, $sdk_root$, gamedata\
$game_ai$ = true, false, $game_data$, ai\
$game_spawn$ = true, false, $game_data$, spawns\
$game_levels$ = true, false, $game_data$, levels\
$game_meshes$ = true, true, $game_data$, meshes\
$game_anims$ = true, true, $game_data$, anims\
$game_dm$ = true, true, $game_data$, meshes\
$game_shaders$ = true, true, $game_data$, shaders\
$game_sounds$ = true, true, $game_data$, sounds\
$game_textures$ = true, true, $game_data$, textures\
$game_saves$ = true, false, $sdk_root$, savedgames\
$game_scripts$ = true, false, $game_data$, scripts\
;
;
$level$ = false, false, $game_levels$
$logs$ = true, false, $sdk_root$, logs\, *.err, Log files
$sounds$ = true, true, $sdk_root_raw$, sounds\, *.wav, Wave files
$textures$ = true, true, $sdk_root_raw$, textures\
$objects$ = true, true, $sdk_root_raw$, objects\, *.object;*.lwo, XRay objects
;$clips$ = true, true, $sdk_root_raw$, objects\, *.clip, Object clips
$maps$ = true, true, $sdk_root$, maps\, *.level, XRay levels
;$groups$ = true, true, $sdk_root$, groups\, *.group, XRay groups
$temp$ = false, false, $sdk_root$, temp\
$import$ = true, true, $sdk_root$, import\, *.object;*.lwo;*.txt;*.xr;*.wav;*.obj;*.ltx, Files
;$detail_objects$ = true, true, $import$, , *.dti, Detail indices
;$omotion$ = true, true, $import$, , *.anm, Object animation files
;$omotions$ = true, true, $import$, , *.anms, Object animation list files
;$smotion$ = true, true, $import$, , *.skl;*.skls, Skeleton motion files
;$sbones$ = true, true, $import$, , *.bones, Skeleton bone data files
;
$screenshots$ = true, false, $sdk_root$, screenshots\
$cache$ = true, false, $sdk_root$, xr_cache\
Перейти в начало страницы
 
 
 ed_dream
сообщение 28.02.2009, 11:24
Сообщение #18


Игроман
**********

Группа: Участник
Сообщений: 823
Регистрация: 14.01.2006
Пользователь №: 2804



Ты по аналогии со Левел эдиторм от ТЧ вбивал?
Просто я туда вообще не смотрел... забыл...
А $sdk_root$ откуда?


Не очень понятно - false, false что точно они означают. Пронятно что это разрешение пользоватся ресурсом. Но почему пара? Может для разрешения пользоватся распакованной структурой и упакованной. Типа фраза true, false означает что переменная мощет читать данные из распакованных папок и не может из архивных (ну или наоборот).

Сообщение отредактировал ed_dream - 28.02.2009, 11:30
Перейти в начало страницы
 
 
 20Km's Of Coast
сообщение 28.02.2009, 11:48
Сообщение #19


Продвинутый геймер
********

Группа: Участник
Сообщений: 273
Регистрация: 28.10.2008
Из: Нижний Новгород
Пользователь №: 9365



Эх...ну наконец-то , *пошёл копаться*
Перейти в начало страницы
 
 
 =Diablo=
сообщение 28.02.2009, 12:08
Сообщение #20


Игроман
**********

Группа: Участник
Сообщений: 884
Регистрация: 14.08.2008
Пользователь №: 8611



Цитата(ed_dream @ 28.02.2009, 11:24) *
Ты по аналогии со Левел эдиторм от ТЧ вбивал?
Просто я туда вообще не смотрел... забыл...
А $sdk_root$ откуда?


Не очень понятно - false, false что точно они означают. Пронятно что это разрешение пользоватся ресурсом. Но почему пара? Может для разрешения пользоватся распакованной структурой и упакованной. Типа фраза true, false означает что переменная мощет читать данные из распакованных папок и не может из архивных (ну или наоборот).

$sdk_root$ взял из СДК ТЧ, что true и false означают, не знаю... Я просто из ТЧ SDK перенес ветки fs.ltx
Перейти в начало страницы
 
 
 
 

 
2 чел. читают эту тему (гостей: 2, скрытых пользователей: 0)
Пользователей: 0

 

Текстовая версия Сейчас: 23.10.2020, 08:48